ATR Discussion Forums Homepage
Forum Home Forum Home > ATR Discussion Forums > Development Forum
  New Posts New Posts RSS Feed - **** NEW: Service Pack 3 Beta 4 ****
  FAQ FAQ  Forum Search   Register Register  Login Login

Forum Locked**** NEW: Service Pack 3 Beta 4 ****

 Post Reply Post Reply Page  123>
Author
Message
Hans Hartmann View Drop Down
Moderator Group
Moderator Group


Joined: October-30-2004
Points: 1715
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hans Hartmann Quote  Post ReplyReply Direct Link To This Post Topic: **** NEW: Service Pack 3 Beta 4 ****
    Posted: June-18-2005 at 2:56pm


Hi everybody,

it took a lot of time, but as promised this morning, I have the next service pack beta ready for you.

Please do yourself and me a great favor and read the readme file (or the text below) BEFORE installing the files.

Download here (9,801,633 bytes)

Best regards,
Hans Hartmann
Flight 1 ATR Gauge Programmer

Here comes the text of the readme:

Flight One ATR 72-500 Service Pack 3 Beta 4

!!!BEFORE YOU INSTALL!!!
This is a beta version! That means it has undergone only very little testing by myself and very few other persons. Though we did the best we could, this version might still cause problems. If you're not interested in testing the fixes and features mentioned below, you shouldn't install it!
Please make sure that you backup your F1ATR.gau and F1ATRB.gau before installing this service pack!!!!

Fixes / Improvements:
- Improved localizer hold in crosswind conditions (see below)
- Disabled VS Hold when App mode is active. This one caused glideslope capture to fail
- CDI is now correctly displayed in RNAV mode (was mirrored)
- Flaps extension flag now works without flickering
- Speed callouts now use icing speeds when ICING warning is on
- TCAS resolutions advisories are now displayed correctly
- Configuration manager volume control fixed. Now you can finally set the volume for the avionics sound ;-)
- De-Ice boots now work with bleed air
- Heading to alt, course to alt and course fix to alt procedure types fixed (no more turning before altitude is reached
- Single channel annunciator now lights when condition levers are moved from FSO or FTR to AUTO
- Hot brakes now cool down faster in flight when the gear is down

New features:
- Stick Pusher
- Autopilot Basic Mode and TCS (see below)
- Clickspot to re-select engines 1 & 2(see below)


Notes

1) Improved localizer hold in crosswind conditions
This was an aircraft.cfg related problem, so that file must be updated:
- Open <your fs folder>\Aircraft\Flight 1 ATR-72-500\aircraft.cfg in notepad (Windows default text editor)
- Find the [autopilot] section
- Replace all existing lines which start with nav_ or gs_ with these:

nav_proportional_control=20.0 //15
nav_integrator_control=0.25 //0.1
nav_derivative_control=0.0
nav_integrator_boundary=2.5 //0.2
nav_derivative_boundary=0.0
gs_proportional_control=20.0 //15
gs_integrator_control=0.5
gs_derivative_control=0.0
gs_integrator_boundary=0.5
gs_derivative_boundary=0.0

- Save the aircraft.cfg and reload the aircraft.

2) Autopilot Basic Mode and TCS
This mode is active as soon as the Flight Director or Autopilot is switched on.
When switched on, it holds the current pitch. If the bank angle is below 6 degrees, the wings level. If it is between 6 and 27 degrees, the basic mode holds current bank angle. If the bank angle is greater than 27 degrees, it falls back to 27 degrees and holds that.
The TCS switch (Touch Control Steering) allows the pilot to sync the pitch mode to the current aircraft attitude. Since this switch is on the back side of the yoke, we can't put it in the correct spot. Instead we used three different locations for it:
- The L SEL switch on the ADU
- The R SEL switch on the ADU
- The registration plate on both, the captain's and the f/o's side

3) Clickspot to re-select engines 1 & 2
Pressing the 'E' key without any modifiers (shift, alt, ctrl) when the FMC keyboard input mode is not enabled causes FS to select engine number 1 instead of 1 and 2. Re-selecting both engines by pressing E+1+2 can be a real pain, so I put a clickspot which re-selects both engines without any hassle. The only thing you need to do is to click the annunciator light right below the GA switch on the control stand.

Please report problems in the development forum at http://atr.flight1.net. You would do me a big favor if you'd check if the problem is already mentioned in another thread or posting there.


Best regards,
Hans
Back to Top
Aetos View Drop Down
Groupie
Groupie


Joined: January-02-2005
Location: Belgium
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote Aetos Quote  Post ReplyReply Direct Link To This Post Posted: June-18-2005 at 7:09pm

Thank you Hans for the great effort in providing a beta patch. I have installed the new gauges and updated the cfg file as well as instructed and flew twice out of LFKJ (Corsica) and landed on the same airport tonite (2 x 15 minutes flights around the airport) and here are my remarks so far :

1. Overall the plane seems to be more responsive than before

2. The LOC is captured everytime using NAV but without a lot of anticipation which has the plane banking excessively left & right to get on track. Capture was made at a 40 degree angle (know it's a bit too much but...)

3. Switching to APP after LOC capture has worked OK

4. Glideslope capture is OK and there is no deviation after Flaps 15, Flaps 30 and gear down as it used to happen before

5. There are no more speed callouts, flaps 15, climb sequence etc.

6. The TCAS test audio message is also missing

That's all for tonite. Hope this might help you .

Back to Top
RUSO View Drop Down
Newbie
Newbie


Joined: June-19-2005
Location: United States
Points: 1
Post Options Post Options   Thanks (0) Thanks(0)   Quote RUSO Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 1:21am
Good Morning Hans

Thanks for the hard work !   I understan coding and it never is easy !

Back course tes

Ok to the point about service pack 3 beta 4. I installed it under your intruction and completed 2 flight. KSEA to KPAE first to the back course of ILS 16 109.3 course 159 degrees, back course 339 degrees. The interception to the back course was achived but the autopilot was hunting the localizer ! It never stabilized.

On the second Flight KPAE to KSEA did the ILS to runway 16R 111.70 course 161 degrees. This time the autopilot properly captured the Localizer.  The glide slope was also captured very nicely. The only problem was the excesive deviation when the Glide slope converged close to the decision hight. At around 450 to 400 the deviation exceded the autopilot input and the autopilot went into reset mode
time to handl fly. I don't remeber having this happen with SP 3 Beta 3.

The new adjustment to the flight dynamics are very good.

Thank you and your team for an excelent product.

I have been around simulation for some time and EXCELLENT work is to be congratulated

Have a great day.

If you have any question let me know. I would kindly reply

RUSO
FLY ATR
Back to Top
Hans Hartmann View Drop Down
Moderator Group
Moderator Group


Joined: October-30-2004
Points: 1715
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hans Hartmann Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 4:16am
Originally posted by Aetos Aetos wrote:


5. There are no more speed callouts, flaps 15, climb sequence etc.
6. The TCAS test audio message is also missing


I had those sounds during yesterdays test flights. Please check the volume settings in the configuration manager - those are far more effective now.
Best regards,
Hans
Back to Top
loac View Drop Down
Groupie
Groupie


Joined: December-10-2004
Location: France
Points: 92
Post Options Post Options   Thanks (0) Thanks(0)   Quote loac Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 6:25am

Thanks Hans for your great Job,

I am still happy with....

Loic

Back to Top
n_oikonomidis View Drop Down
Newbie
Newbie


Joined: October-30-2004
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote n_oikonomidis Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 10:40am
Thanks for the new service pack Hans 

Just tested and I cannot hear the "click" sound of the light switches, the "bells" of the seatbelts and no smoking siwtches and finally (and most important) the trim whooler.

I double checked it (installed the old f1atr.gau /f1atrb.gau and all sounds came back), so it appears that the problem is in the new gau files.

Thanks again,
Nikos
Back to Top
Swen View Drop Down
Newbie
Newbie


Joined: November-04-2004
Location: Germany
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Swen Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 10:42am
Nice Nice Nice!!! :)
With best wishes,

Swen

Back to Top
Hans Hartmann View Drop Down
Moderator Group
Moderator Group


Joined: October-30-2004
Points: 1715
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hans Hartmann Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 11:13am
Originally posted by n_oikonomidis n_oikonomidis wrote:

Thanks for the new service pack Hans 

Just tested and I cannot hear the "click" sound of the light switches, the "bells" of the seatbelts and no smoking siwtches and finally (and most important) the trim whooler.

I double checked it (installed the old f1atr.gau /f1atrb.gau and all sounds came back), so it appears that the problem is in the new gau files.


Please check the ambient volume setting in the configuration manager. This might be the reason. I can hear all sounds here.
Best regards,
Hans
Back to Top
n_oikonomidis View Drop Down
Newbie
Newbie


Joined: October-30-2004
Points: 6
Post Options Post Options   Thanks (0) Thanks(0)   Quote n_oikonomidis Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 11:56am
Originally posted by Hans Hartmann Hans Hartmann wrote:

Please check the ambient volume setting in the configuration manager. This might be the reason. I can hear all sounds here.


Perfect


Regards,
Nikos
Back to Top
bisinchi View Drop Down
Senior Member
Senior Member


Joined: October-31-2004
Location: France
Points: 145
Post Options Post Options   Thanks (0) Thanks(0)   Quote bisinchi Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 2:40pm

Hi,

Great stuff,

I'll check it out, thanks for the update, that's a great way to finish a great day (I was at the Paris Air Show today and that was really nice!),

Francois

 

 

Back to Top
Swen View Drop Down
Newbie
Newbie


Joined: November-04-2004
Location: Germany
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Swen Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 4:00pm

OK first Problem, TCAS dont work right... I've flight only online and i have a yellow point in center. I get out and load ai. Now i have AI Traffic that works. So, i get online and i have the AI Traffic in TCAS and dont go away... :(

AP Dont work right. Everytime the same... If i switch from NAV to HDG, the ATR means to do what it will...

I say left, ATR means right. With a bank more than 40 angel...

Here is a Picture:

ATR error

Hans i hope you have an idea... :(

With best wishes,

Swen

Back to Top
w6kd View Drop Down
Newbie
Newbie


Joined: October-31-2004
Points: 29
Post Options Post Options   Thanks (0) Thanks(0)   Quote w6kd Quote  Post ReplyReply Direct Link To This Post Posted: June-19-2005 at 10:12pm

Hans;

  Thank you for the update.

  RNAV course display in CDI looks OK.

  No problems with sounds here.

Bob Scott
ATP IMEL Gulfstream II-III-IV-V  L-300

Back to Top
Aetos View Drop Down
Groupie
Groupie


Joined: January-02-2005
Location: Belgium
Points: 43
Post Options Post Options   Thanks (0) Thanks(0)   Quote Aetos Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 7:29am

5. There are no more speed callouts, flaps 15, climb sequence etc.
6. The TCAS test audio message is also missing

I had those sounds during yesterdays test flights. Please check the volume settings in the configuration manager - those are far more effective now.

Hello Hans,

Thank you for your answer. I checked this and the volume bars were already almost all the way to the right and all sounds could be heard when tested within the config. manager. I re-installed the previous gauges and sound was OK again within the cockpit. Re-installed the beta ones then gone again (call-outs + TCAS). Sorry .

Back to Top
Hans Hartmann View Drop Down
Moderator Group
Moderator Group


Joined: October-30-2004
Points: 1715
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hans Hartmann Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 8:19am
Hmm. I still hear everything with the beta version. May be there's something wrong with your ATR.cfg file. Please go to <your FS folder>\Flight One Software\Flight One ATR 72-500 and open ATR.cfg with notepad. The "sounds" section should look like this:

[Sounds]
Copilot=1
TCAS=1
GPWS=1
Warnings=1
Ambient=1
Copilot Volume=19
TCAS Volume=19
GPWS Volume=19
Warnings Volume=19
Ambient Volume=19
Best regards,
Hans
Back to Top
Hans Hartmann View Drop Down
Moderator Group
Moderator Group


Joined: October-30-2004
Points: 1715
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hans Hartmann Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 8:21am
@Swen: I did a flight on VATSIM this morning and had no unwanted tcas targets at all. Everything worked just fine. Do you use FSUIPCTCAS=1 in your ATR.cfg?
Best regards,
Hans
Back to Top
Sinbad View Drop Down
Newbie
Newbie


Joined: January-06-2005
Location: United States
Points: 11
Post Options Post Options   Thanks (0) Thanks(0)   Quote Sinbad Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 10:30am
Hans,

Maybe I have missed something. That is the first I have heard of using "FSUIPCTCAS=1". What section should this be in, and where did I miss this info?

Thank you,
Steve
Back to Top
Hans Hartmann View Drop Down
Moderator Group
Moderator Group


Joined: October-30-2004
Points: 1715
Post Options Post Options   Thanks (0) Thanks(0)   Quote Hans Hartmann Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 10:51am
It controls whether the TCAS uses the trafficinfo.dll or fsuipc.dll as data source for other aircraft. By now, I know of no difference between both though it seems that trafficinfo.dll can handle more aircraft.
Best regards,
Hans
Back to Top
Swen View Drop Down
Newbie
Newbie


Joined: November-04-2004
Location: Germany
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Swen Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 1:51pm

Ok Hans, my fault i dont know about the CFG and Set it to one.

But you're right. My AP Problem is not cleared with your Service Pack and i have this problem still before SP3 B4... Today i will install the special AP Gauge and look what happens if i turn off NAV to HDG. :) I hope i can tell you my problem, i hope i can get it of this gauge. . I will contact you again.

With best wishes,

Swen

Back to Top
buffi View Drop Down
Groupie
Groupie


Joined: November-01-2004
Location: Germany
Points: 63
Post Options Post Options   Thanks (0) Thanks(0)   Quote buffi Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 2:23pm

I have three questions caused by the new patch.
1. Stick Pusher - as a new feature. What does it mean, how does it work?
2. TCS (Touch Control Steering) - How should it work? If I push one of the 3 clickspots the bankangle is fixed but the pitch always goes to zero, like ALT. How to use it correctly?
3. Clickspot re-selecting both engines - Where is it, the annunciator light right below the GA switch? Sorry, I did not find it.
4. Fixes - What does that mean "Heading to alt, course to alt and course fix to alt..."?

The TCAS often shows a  fixed AP symbol. (24+)
Whe I start "Ready for Boarding" the overhead panel shows some lights are on which were off before the patch (?).
Glideslope capture works fine.

best regards,
buffi (EDDH)

...excuse my english - feel free to ask what I would like to say...
Back to Top
Swen View Drop Down
Newbie
Newbie


Joined: November-04-2004
Location: Germany
Points: 23
Post Options Post Options   Thanks (0) Thanks(0)   Quote Swen Quote  Post ReplyReply Direct Link To This Post Posted: June-20-2005 at 4:53pm

Hi Hans,

i have that for you. :)

PLAN EDVE -> EDLW FL140 SID and STAR are Norta4U and Warburg4A I put sid and star together to a route. OK now i fly with NAV . 12nm inbound DOM i put HDG to 243 and push HDG on AP and bingo... HDG HOLD dont switch to 1 and my ATR goes to the right. No HDG controll with AP. Here a screenshot for you:

atr error

OK AP board STBY. AP of... Stabelize the ATR, turn left and then switch on HDG, on AP. After this, the ATR get HDG HOLD 1, stops turning then get lat fd and follow it likes normal...

OK Hans, now its your part.

With best wishes,

Swen

Back to Top
 Post Reply Post Reply Page  123>
  Share Topic   

Forum Jump Forum Permissions View Drop Down

Forum Software by Web Wiz Forums® version 11.10
Copyright ©2001-2017 Web Wiz Ltd.

This page was generated in 0.156 seconds.